Misalkan jaringan suatu kantor sbb:

lan-kantor

Kantor tersebut melakukan bandwidth management untuk setiap klien di jaringan dengan menggunakan fasilitas simple queue dari RouterOS dengan bandwidth masing-masing 512 kbps/user.

Anda bisa mengkonfigurasi secara langsung dengan mengeksekusi perintah berikut di New Terminal:

for i from=2 to=254 do={ /queue simple add name="queue-usr$i" target="10.255.255.$i" queue=default/default max-limit=512k/512k comment="queue staff"}

Penjelasan:

  • for digunakan untuk perintah perulangan dimana “from” adalah nilai awal dan akan diiterasi satu persatu hingga nilai akhir yang ditentukan pada “to”. “i” adalah nama variabel yang akan diiterasi. Sedangkan :”do” adalah script yang akan dijalankan pada setiap iterasi perulangan.
  • Contoh lain perulangan dengan for dengan mencetak angka dari nilai 1 hingga 10. Untuk mencetak menggunakan perintah “:put” dan variabel yang digunakan adalah “x”.
    for x from=1 to=10 do={ :put "cetak $x" }
  • Perintah untuk konfigurasi simple queue pada dasarnya adalah
    /queue simple add name="queue-usr2" target="10.255.255.2" queue=default/default max-limit=512k/512k comment="queue staff"

    Namun untuk membedekan queue setiap IP maka “$i” atau isi variabel “i” menggantikan nilai 2 di atas, maka dari target=”10.255.255.2” menjadi target=”10.255.255.$i”

Hasilnya dapat dilihat pada Winbox dengan menekan tombol Queues –> pilih tab Simple Queues

queue kantor

Untuk hasil pengecekan bandwidth pada salah satu user ke speedtest.net sebagai berikut

queue-kantor2

Misalkan Anda diminta untuk melakukan pengaturan bandwidth sebagai berikut:

  1. Di jam kerja, 08:00 – 17:00 bandwidth dari masing-masing user adalah 256 kbps
  2. Di luar jam kerja dari jam 17:00 – 08:00 bandwidth dari masing-masing user adalah 1 Mbps

Untuk dapat melakukan konfigurasi pengaturan bandwidth di atas maka Anda bisa menggunakan fitur scheduler di RouterOS. Namun pada tulisan ini untuk mempermudah kita akan membuat fungsi agar penulisan pada script pada scheduling tidak terlalu panjang.

Pembuatan Fungsi

Fungsi atau function merupakan rangkaian perintah yang dapat dipanggil oleh script yang lain, sehingga pembuat script dapat memanfaatkan script tersebut sewaktu-waktu bila dibutuhkan. Dengan cara ini pembuat script tidak perlu menuliskan rangkaian perintah tersebut lagi namun cukup memanggil nama fungsinya saja.

Pembuatan function pada RouterOS mengikuti format berikut:

:global nama_fungsi do={ perintah1; perintah2; perintah3 }

Contoh fungsi dengan nama cetak

:global cetak do={ :put “halo $nama” }

Untuk eksekusi fungsi tersebut dengan perintah

$cetak nama=”joni”

Hasilnya

halo joni

Fungsi yang terbentuk akan dimasukkan ke dalam enviroment sistem dari RouterOS. Hal ini dapat dilihat dengan mengakses menu System –> Scripts –> pilih tab Enviroment, atau menggunakan perintah:

/system script enviroment print

Fungsi yang akan kita buat digunakan untuk mempermudah pengeksekusian perintah di penjadwalan. Untuk membuat fungsi klik menu New Terminal jalankan perintah berikut:

:global setque do={/queue simple set [ find comment="queue staff" ] max-limit="$a/$a"; /log info message="Ubah Bandwidth ke $a"}

Fungsi di atas membutuhkan argumen “a” yang meminta nilai bandwidth yang akan diberikan ke queue. Untuk mengeksekusinya dengan perintah

$setque a=2M

Maka bandwidth untuk setiap klien akan berubah menjadi 2 Mbps untuk melihatnya bisa pada menu Queues –> Simple Queues

queue-kantor6.png

Penjelasan untuk fungsi di atas adalah:

  • Dasar dari perintah di atas adalah
    /queue simple set [ find comment="queue staff" ] max-limit=256k/256k

    Dimana find digunakan untuk mencari untuk konfigurasi dengan comment dengan nilai “queue staff”, bila ada yang sama akan diganti max-limit menjadi 256k

  • Perintah:
    /log info message="Ubah Bandwidth ke $a"

    digunakan untuk menuliskan log ketika script dijalankan dengan menggunakan tingkat severity “info” atau information

Penjadwalan Perintah

Scheduler digunakan untuk melakukan penjadwalan pada RouterOS. Untuk melakukan penjadwalan sbb:

  1. Klik menu System –> Scheduler
  2. Klik tombol +
  3. Set penjadwalan sbb:
    • Name, diisikan dengan nama dari penjadwalan
    • Start Date, tanggal penjadwalan akan dieksekusi. Bila Anda ingin segera dilakukan Anda tanggal hari ini.
    • Start Time, diisikan jam dan menit keberapa penjadwalan ini akan dilakukan. Bila Anda hendak jalankan untuk jam 8 isikan” 08:00:00”.
    • Interval, berapa periode penjadwalan ini akan dijalankan. Apabila ingin dileksekusi setiap hari (1 hari sekali) ubah menjadi “1d 00:00:00”
    • On Event, adalah script yang akan dijalankan pada saat penjadwalan

Untuk penjadwalan jam 8 untuk bandwidth menjadi 256 kbps konfigurasinya adalah:

  • name: bw-jam8
  • Start Time: 08:00:00
  • Interval: 1d 00:00:00
  • On Event:
    :global setque
    $setque a=256k

Untuk penjadwalan jam 17 untuk bandwidth menjadi 1 Mbps konfigurasinya adalah:

  • Name: bw-jam17
  • Start Time: 17:00:00
  • Interval: 1d 00:00:00
  • On Event:
    :global setque
    $setque a=1M


Hasil dari konfigurasi di atas maka setiap perubahan bandwidth untuk klien akan berubah setiap jam 8 dan 17. Anda bisa tambahkan untuk perubahan bandwidth yang lain misalkan untuk jam istirahat. Apabila Anda hendak membuat bandwidth menjadi unlimited gunakan script “$setque a=0” atau akan mengubah max-limit dari simple queue menjadi 0/0 atau unlimited. (Toto)

Iklan